Hyper-V Failovercluster vermeintliche Zeitdifferenz 2012R2

Betroffenes Produkt: Microsoft Server 2012R2
von
P R O B L E M
Kommunikation zwischen den Knoten eines Failoverclusters schlägt fehl und es wird eine vermeintliche Zeitdifferenz gemeldet.
U R S A C H E
Dir Ursache kann sein, dass dem Clusterknoten die Ports ausgegangen sind. Sollten zum Beispiel noch zusätzliche Anwendungen Ports verwenden kann das passieren.
Geschätzter Zeitaufwand: 10 Minuten

Es gibt wohl bei den #Failoverclustern (wir hatten / haben das jetzt bereits zwei Mal) ein Problem dass einem Clusterknoten die Ports ausgehen und er die #Cluster-Kommunikation ablehnt. Um dem vorzubeugen vermeideam besten (wie in unserem Fall) die Installation von Drittanbieter-Software auf einem der Knoten. Bei uns war das Bandlaufwerk an einem der Knoten installiert und damit auch der "Acronis Storage Node". Auch die Management Konsole wurde darauf installiert... und die war wohl das Provlem.

Laut Microsoft ist es ohnehin best practice, einen Clusterknoten nur dafür zu verwenden. Aber auf jeden Fall solltest Du Software vermeiden, die viel über TCP/IP kommuniziert... in der Regel fast jede moderne Software mit Webinterface ... zum Beispiel Acronism Trendmicro Konsole, etc.

Die solltest Du ausnahmslos auf dem „außenstehenden“ Domaincontroller installieren und dort dann auch das Bandlaufwerk o.Ä. anschließen. Klar muss dann das Backup über das Netzwerk laufen, aber der Geschwindigkeitsvorteil überwiegt ein potentielles Fehlerpotential nicht.

Sollte das Problem dennoch auftauchen... beschreibe ich hier wie ich es in den Griff bekommen habe.

Es äußert sich zum Beispiel beim Zugriff via RDP - Fehlermeldung besagt dass eine vermeintliche Zeitdifferenz besteht. In unserem Fall konnte dann auch nicht auf den Storage Node von Acronis zugegriffen werden. Der Failovercluster funktioniert nicht richtig. Es war keine Livemigration mehr möglich, etc

Als Lösung fand ich diesen Artikel im Technet der auf den ersten Blick aber nichts mit dem Problem zu tun hat.

https://social.technet.microsoft.com/Forums/en-US/69449ce9-ea58-48ec-b675-c55480ba4bbb/windows-server-2012-and-tcpip-maxuserport?forum=winserverPN

1. TCP TIME-WAIT Delay:

In der Registry den Wert #TcpTimedWaitDelay in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters auf 30 Sekunden setzen.

Sollte der Eintrag nicht existieren, erstelle ihn bitte.

2. MaxUserPort:

Wieder Registry: MaxUserPort in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters auf 65,500 setzen

Sollte der Eintrag nicht existieren, erstelle bitte aich den.

"Dein Cluster kann jetzt wieder kommunizieren!"